[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: root cannot login tho sudo user can



Karl L wrote:
On Wed, 12 May 2004 07:54:04 -0400
Bob Chiodini <chiodr kscems ksc nasa gov> wrote:


On Wed, 2004-05-12 at 02:53, Karl L wrote:


Thanks for your reply.  I apologize for not providing more information.
My main problem is that I don't get an error message and can't find anything in the logs that reflects the situation.  But, here's what happens when I try to login as root (and I've tried this with both the smp and non-smp version of 2188 as well as with the previous kernel release with the same result):  I get a username prompt, I enter the username 'root'; I then get a password prompt, I enter the correct root password and then -- a BSOD! (though the mouse cursor is still 'alive').

So, the first thing I tried after this had happened twice was to login as my 'emergency user' (an ALL access sudoer) and entered  'sudo passwd root', got the password change prompt, entered a new password, confirmed it (and it seemed to be accepted normally).  Then I checked /etc/passwd
visually (it seemed OK) but then I checked it with 'sudo /usr/sbin/pwck'
(which should examine both /etc/passwd and /etc/shadow for syntax problems) and, though both files appeared to be intact, there was no return code from pwck that I could find in any log (even 'sudo /usr/sbin/pwck > pwcktest.txt' produced an empty file).  After this, I tried another root login with the "new" password but got the same Blue Screen of Death as before. BTW, my very first examination of /etc with
ls did turn up a 6-byte password.lock file (which I simply renamed password.lock.problem and left there)

So, as a sudoer, I read thru all the logs in /var/log looking for some indication of the problem but could find nothing that struck my eye (which I hasten to add did not really know what to be looking for, truth be told).

What I'd like to do is follow the sequence of scripts and modules that are called after a successful login but I don't know enough about this system to identify that sequence. Any guidance here would be much appreciated.

Thanks

Karl L



Is the root home directory intact?


Maybe something in the /root/ directory is trying to start and crashing the system.

What happens if you just try to su (not su -)in a terminal window?
If you can login this way, the password is working. I think it is because of the BSOD that you are getting. It looks like X isn't starting for root. Possibly a corrupted config file in /root/ .



-- Robin Laing



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]