[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RHN/up2date killed my fedora



On 12 May 2004 at 18:13, fedora-list-request redhat com wrote:

> I tried using the RHN to update all my installed software. One or 2
> packages had corruption but after hours of tinkering I decided to try
> "continue anyway" and see if it would just skip trying to install
> those packages.
> 
> Instead, up2date/rpm just failed and stopped when it reached those
> packages. Then my desktop was acting strangely so I logged out.
> 
> I could not log back in. I would see a text prompt (not the graphical
> prompt I'm used to) for a second but it would disappear, only to
> reappear for a brief second a bit later, and so on, forever. I tried
> rebooting but when I get to where the graphical login screen should
> be, I get an error:
> 
> id "x" tried to respawn too quickly waiting 5 minutes
> 
> (or something like that). I tried logging in to the console as root
> and doing rpm -Uvh *.rpm on the /var/spool/up2date dir but it said the
> files were already installed. Reboots continued to barf in exactly the
> same way.
> 
> I just (re)installed from my Fedora Core 1 CDs and did an "update
> current installation" and now I'm back to the "text login then
> immediate blank screen" repeating situation.
> 
> I'm assuming I'll need a full system reinstall now (F*&#!!!!!!!). Any
> ideas before I wipe and reinstall? There was nothing of value on the
> system yet but still... grrr... just like Windows. :-(

I had this problem, or one very much like it, and it did not prove 
necessary to re-install FC1 although there were moments when I 
thought that it might have been quicker.

I do not know what causes the problem.  I speculate that the size of 
the downloads when initially updating a fresh install of FC1 are 
susceptible to server load induced errors, probably a corner case 
that is not likely to be encountered when testing up2date against low 
volume test repositories.  In any case the fix is tedious, but not 
difficult.  You basically have to manually reinstall all of the 
components for X (XFree) from the rpms at FC, ignoring dependencies 
and forcing an overwrite of files and packages.  This includes the 
font rpms and the hwdata-0.103.1-1.noarch.rpm.  You might have to re-
install gnome as well.  To ease the pain I suggest that you install 
webmin:
http://prdownloads.sourceforge.net/webadmin/webmin-1.140-1.noarch.rpm

and install
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386
/yum-2.0.5-1.noarch.rpm

before doing anything else.

Whether or not you re-install gnome your desktop may be munged, in 
which case you have to manually add back the missing apps to the task 
bar.  There might be a quicker way of doing this but I never found 
it.  Packages subsequent to the error point in the mass update may 
have to be re-installed by hand to bring the rpm db into sync with 
what is actually on the disk.  However, I do not know this to be the 
case, I simply did this whenever I encountered a discrepancy and over 
time all of the artifacts of the late unpleasantness have 
disappeared.

I hope that this works for you.  Good Luck.

Sincerely,
Jim
-- 

***     e-mail is NOT a secure channel     ***
James B. Byrne                 mailto:ByrneJB.<token>@Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive                 vox: +1 905 561 1241
Hamilton, Ontario               fax: +1 905 561 0757
Canada  L8E 3CE               delivery <token> = hal



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]