[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: USB Flash stick



On Mon, 2004-05-17 at 22:28, Chadley Wilson wrote:
> Hi folks
> 
> Just a question, Why is it that my flash stick formatted fat32 works on
> all linux and Winoze systems, but no-one else's flash sticks will work.
> they are all the same make. Tday I left mine at home and I have tried 7
> others, 3 of which are also 256mb the same size as mine. I have even
> reformatted a few with windows and linux.
> And yet I get an invalid block device error. I don't get it. I have
> tried running mkfs.vfat and it works the drive is formatted but I can't
> mount it in linux but it works in windows!
> Hows that, format with linux and it don't work in linux but it works in
> windows. Every time it says the same thing.
> 
> mount: /dev/sda1 is not a valid block device
> 
> I loaded a fresh copy of FC on Friday and it detected my flash drive
> today I have reloaded the same system twice and it still will not mount
> the flash. 
> I bet if I bring my flash in tomorrow it will work.
> Any-one know why my flash drive is so special? 
> Anything I can do to make it read all flash drives?
> 
> 
> -- 
> Chadley - Linux Rocks
> Welcome to my world.

I'm not sure if this will help you, but I have a link to the page (below) where you
can download the manual for my Apacer HT202 1G memory stick. It outlines on page 10,
how to format it for linux (Which can also be read in windows, and I've tested
it in Win2k & WinXP. As it reads OK. And that's provided it's NOT formatted in
Windows for some reason) It reads OK on the following versions of Linux
I use... RH9, FC1 and RHEL3.

http://www.apacer.com/apacer_english/support_html/download.asp

Hope if helps,
Wolf




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]