[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems getting 2 NICs to work.



Am Mo, den 17.05.2004 schrieb Kevin Kimmell um 19:29:

> I tried this and get "RTNETLINK answers: Invalid Argument". Then I tried 
> to just manually add these routes:

Certainly because of a faulty command line. See

http://www.akadia.com/services/redhat_static_routes.html

for some explanations on how the route-ethX file has to look.

> ip route add 12.168.88.0 dev eth0
> ip route add 204.117.218.0 dev eth1

Those are wrong/incomplete. What shall 12.168.88.0 and 204.117.218.0 be,
the network address or the gateway?

ip route add 12.168.88.0/24 dev eth0
ip route add 204.117.218.0/24 dev eth1

What you did is creating a host route.

> It accepts these but can't seem to do lookups. I get a "connect: Network 
> is unreachable" with any ping or trace attempt. I know there is 
> something simple missing here. I'm reading this Advanced Routing HOWTO 
> and it seems section 4.2 is exactly what I'm trying to do but I'm having 
> a bit of trouble making sense of what commands go into what files.

See i.e.
http://www.redhat.com/archives/redhat-list/2003-January/msg02394.html

> ++ Kevin Kimmell + kevin_AT_dynamictrend.com + Dynamic Trend, Inc. ++

Alexander


-- 
Alexander Dalloz | Enger, Germany | GPG key 1024D/ED695653 1999-07-13
Fedora GNU/Linux Core 1 (Yarrow) on Athlon CPU kernel 2.4.22-1.2188.nptl
Sirendipity 20:14:24 up 4 days, 17:59, load average: 0.33, 0.78, 0.57 
                   [ ÎÎÏÎÎ Ï'ÎÏÏÎÎ - gnothi seauton ]
             my life is a planetarium - and you are the stars

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]