[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: USB Flash stick



Coume - Lubox.com wrote:
On Mon, 2004-05-17 at 19:03, Robin Laing wrote:

The problem was that I hadn't even mounted the stick yet. This happened the very first time that I plugged the stick in.

I played with autofs and the stick would mount some times and then others it wouldn't. I just gave up as I needed to get some work done.

I will check out your site though. I would like autofs to work.

I think it may have something to do with changing usb devices.

When time permits I will take another look at it.


Hi Robin!

I experienced your problem for more than one year. I was the only one
using linux on my laptop at uni and the only usb key which was working
was mine, but it took me almost 2 months to understand how to get it to
work each time I want it to work....

Ok, then what is my solution to mount all the key I tried to use till
now...
First of all, forget about the automount. once I decided to do it by
command line, it evrything started to be much more easier.

Basically, there are 2 kinds of keys, the ones that will mount as
/dev/sda and the ones that will mount as /dev/sda1
Basically, if you get the error:
mount: /dev/sda1 is not a valid block device

Try to mount the key as /dev/sda and it should work...
don't ask me why, but ... it's like that. When I asked others persons
before they all tell me that /dev/sda should not be used to mount an usb
key, but it proved to work for me.
Thxs to this stupid mount /dev/sda or /dev/sda1 I managed to use all the
usb keys I came accross...

One info, it's seem that /dev/sda has to be used in presence of USB 2.0
device.

Ok, that's my 2 euro Cents.... I hope that it will help you and if not
sorry for this long and useless email :D

Ludo

btw, in gnome, there is the ability to add "disk icon" to mount them. I
have one set up for /dev/sda and one /dev/sda1... when one do not work,
I use the the other one...
________________________________________________________________

I will don't use my desktop icons enough to worry about it.


I just use the mount tool when I need it. It works quickly and I am happy for now.

I have received a reply that in FC2, support is much better. I will wait a few weeks before seting FC2. I have to ensure certain applications are available.

On the first day, I spent a few hours working with autofs to try and get the automount to work. It was okay for a short number of tests. Next time it didn't work.

One of the people at work sent a script around and it has worked once or twice.

--
Robin Laing



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]