Error upgrading mozzila using Yum

Clint Harshaw clint at
Tue May 18 23:11:34 UTC 2004

Grewal, Jaideep wrote:
> Hi,
> I am using Yum to update packages. Repeteadly Yum fails on updating mozilla package to the 1.4.1-18 version because of Bad MD5 checksum. Currently the release installed on the machine is 1.4.1-17. After failing on getting mozilla package it drops the updating process and does not proceed.
> Is there any problem with the mozilla package on the site from which yum is pulling the packages
> i.e.
> I have tried to run #yum clean all , just in case some bad reference file is hanging around. I have tried updating selectively the mozilla group of packages, still gives the same error. Error I get is as below -
> # yum install mozilla

Hi Jaideep,

There are two things I can recommend for you to do:

First, edit your /etc/yum.conf file to use mirrors. You can copy this 
yum.conf in place of your own to get you going:

Secondly, have you thought about an upgrade to Mozilla 1.6? It's easy to 
do following these instructions:

Step 1: As root, add these three lines to the above file that you are 
storing in /etc/yum.conf:

name=Mozilla SeaMonkey Releases

Step 2: As root run this command:
yum update mozilla

IMPORTANT: Note that this upgrade to Moz 1.6 will break the default 
installation of Epiphany (and Galeon if it's installed). If Epiphany or 
Galeon are important to you, then you may want to reconsider upgrading 
to Moz 1.6, or get newer installations of Epiphany and Galeon from 
another repo.

Hope this helps,

Clint Harshaw  <clint at>

More information about the fedora-list mailing list