[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Severe keyboard problem after upgrading FC1->FC2

On Wed, 2004-05-19 at 10:05, Colin Paul Adams wrote:
> I have just upgraded from FC1 to FC2 this morning.
> After re-booting the system, kudzu prompt screen came up, but no
> matter which key I pressed, kudzu was not invoked.
> Matters became clearer when I tried to login - there is no response
> from the keyboard.
> I've tried booting with various kernel options, but nothing I try 
> seems to get my keyboard back.
> I'm now logging on via telnet from my firewall machine. I'm running a
> yum update to see if that will fix the problem.
> I get the message:
> Error getting file
> http://fedora.redhat.com/releases/fedora-core-2/headers/headers.info
> Yum seems to be continuing, although nothing has appeared in the log.
> If I now run kudzu from the command line, It reports that USB hub
> number 2 has been removed from my system. My keyboard is NOT a USB
> keyboard, and in any case, it works with GRUB at boot time.
> My mouse IS a USB mouse, but this IS working.
I had a similar problem before, and wasn't sure what the problem was.

however I found that disabling gpm resolved the problem.

After further investigation, i found that on some motherboards, if the
mouse is set up as a PS2 mouse, but is in actual fact a USB then this
problem occurs.

I resolved it by dissabling gpm (chkconfig --level 345 gpm off), then
starting up and configuring the mouse (redhat-config-mouse
service-config-mouse) and making sure it was USB, then re-enabling gpm
every thing worked fine.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]