Fedora Core 2 - Can't get mail, download or browse web pages

Steven P. Ulrick ulrick2 at faith4miracle.org
Thu May 20 08:02:50 UTC 2004

Hello, Everyone :)
I looked through my complete Fedora list archives, in addition to
checking Bugzilla, and I've found nothing about this problem, so here
I had this problem yesterday, but for safety's sake, I did a fresh
install of Fedora Core 2 just to make sure I didn't hose something after
my original install.
Here's the problem: to all appearances, I can (using Kppp) connect to
the internet like always have.  I even can "connect" at the speeds that
I usually connect at (45333 and 49000)  Problem is, I cannot load any
web pages (I've tried Konqueror, Mozilla and Lynx) or get my mail

For the sake of comparison, here is a screen shot (taken in Fedora Core
1, since I can't check my mail in Fedora Core 2) of the Kppp statistics
window While I am checking my email with Sylpheed:

Here is a screen shot from Fedora Core 2, taken shortly after I connect
to the internet:

You will notice that in the first screen shot, taken while running
Fedora Core 1, there is what appears to me to be normal activity.  You
will further notice in the second screen shot, taken in Fedora Core 2,
that the graph at the bottom is almost completely flat, and that there
is virtually no activity of any kind, compared to the screen shot from
Fedora Core 1.

Here are a few lines from when I ran "ping" on my internet providers
address, followed by the summary line:

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=0 ttl=255 time=89.7 ms
64 bytes from icmp_seq=1 ttl=255 time=87.9 ms
64 bytes from icmp_seq=2 ttl=255 time=86.9 ms
64 bytes from icmp_seq=3 ttl=255 time=86.9 ms
64 bytes from icmp_seq=4 ttl=255 time=84.9 ms
64 bytes from icmp_seq=5 ttl=255 time=89.9 ms
64 bytes from icmp_seq=6 ttl=255 time=103 ms
64 bytes from icmp_seq=7 ttl=255 time=86.9 ms
64 bytes from icmp_seq=8 ttl=255 time=85.9 ms
64 bytes from icmp_seq=9 ttl=255 time=86.9 ms
64 bytes from icmp_seq=10 ttl=255 time=86.9 ms
64 bytes from icmp_seq=11 ttl=255 time=87.9 ms
64 bytes from icmp_seq=12 ttl=255 time=88.9 ms
64 bytes from icmp_seq=13 ttl=255 time=88.9 ms
64 bytes from icmp_seq=14 ttl=255 time=87.9 ms
64 bytes from icmp_seq=15 ttl=255 time=86.9 ms
64 bytes from icmp_seq=16 ttl=255 time=155 ms
--- ping statistics ---
112 packets transmitted, 111 received, 0% packet loss, time 111137ms
rtt min/avg/max/mdev = 84.994/92.441/307.962/21.718 ms, pipe 2

As you can see, all of the packets were received.  The present opinion
(no offense intended :)  They were nice enough to hook me up with their
Linux Guru) of the tech support person from my internet provider is that
this probably indicates that my modem is not at fault, since every
packet that I sent was received.

I apologize for not copying the error message I get whenever I try to
browse to a web page, but it is exactly the same message that I get
whenever I accidentally try to surf the net before I actually connect :)

In summary, the undesirable behavior (FC2) looks like this:
1. Fresh install (not an upgrade) of Fedora Core 2.  (I haven't applied
the updates that are available yet.  From my brief perusal of them when
I downloaded the FC2 images, I don't think they are related to this
problem anyway)  In addition, I chose to install Every Package. (Over 6
2. Reboot after installation completes, and first thing, try to connect
to the internet.  No Joy :(  Can't load websites, can't check mail.

Also, as an experiment, I chose to not configure a firewall.  This had
no effect on the problem.  Still can't load websites or check mail.

In contrast, I also reinstalled Fedora Core 1 on a separate harddrive
(right before my reinstall of FC2) and I had the following results while
attempting to browse the internet:
1. Fresh install (not an upgrade) of FC1.  No updates applied.  I chose
to install Every Package.
2. Reboot after installation and attempt to connect to the internet. 
Full Joy :)  Every browser works, mail works.

In closing, just to clarify, I want to make clear the things that are
the same in both of these scenarios:
Same computer
Same Modem
Same Internet Provider
Same Phone System
Same Phone Cables

The only differences are that FC1 and FC2 are on different harddrives.

If you can think of anything else that you need to know, let me know and
I'll be glad to oblige :)
I'm going to do some other work now in FC2 (Compile KDE from CVS HEAD,
previously downloaded, of course :)), but I'll reboot into FC1 later to
see what you've thought of :)

Have a Great Day :)
Steven P. Ulrick

More information about the fedora-list mailing list