[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Sound CS4232 on Core 2



On Wed, May 19, 2004 at 11:20:51PM -0700, Adam L. Klein wrote:
> Greetings all.  I've successfully upgraded from Core 1 to Core 2 on my 
> Dell OptiPlex GX-1 and everything with the exception of sound is running 
> smoothly.  When I boot, I get a "no /dev/dsp" error, though there is a 
> /dev/dsp and I've even done a chmod 777 to make sure it's accessible.
> 
> Under my previous FC-1 install, sound worked flawlessly.  Any advice, 
> insight, etc?  I tried /sbin/sndconfig and it complains of a soundcore.o 
> missing (and I know sndconfig is depricated in FC2).  I'd really like to 
> be able to listen to CDs and have sound working.
> 
> Thanks all.
> 
> Adam Klein

I have a similar problem.  My modules.conf from FC1 included the following:
alias sound-slot-0 cs4232
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
options sound dmabuf=1 
alias synth0 opl3
options opl3 io=0x388 
options cs4232 isapnp=1

Simply copying this into modules.conf for FC2 didn't work:
$ /sbin/modprobe sound-slot-0
FATAL:  Module cs4232 not found.

I've also seen reference to snd-card-cs4232 which likewise give:
$ /sbin/modprobe snd-card-cs4232
FATAL:  Module snd_card_cs4232 not found.

In FC1 I had to use sndconfig to get sound to work (redhat-config-soundcard
didn't see it and neither does system-config-soundcard in FC2).  I notice
that sndconfig is not included with the FC2 distro....

Paul



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]