[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Boot Floppy > 1440



On Friday 21 May 2004 01:24, Ed Stewart wrote:
> I've got Fedora Core 2 installed on a relatively old machine that has
> always had SCSI boot issues. Previous OSes (Red Hat 7.2 and 6.1) were
> booted from a floppy and worked fine.
>
> Fedora didn't give me a chance to create a boot floppy at install time, so
> I booted from the CD in rescue mode and was able to run mkbootdisk.
> However, there's not enough room on the floppy! It looks like vmlinuz and
> initrd.img have grown quite a bit. Both boot.msg and syslinux.cfg are 0 in
> size on the resulting floppy.
>
> I've tried mkbootdisk with --device /dev/fd0u1760 for example, but that
> doesn't work. If I pre-fdformat a disk, mkbootdisk just reformats and drops
> on the 1440 image.
>
> Is there any way around this? How can I get a boot image that actually fits
> on a floppy? It's going to get worse too because the smp kernel is even
> larger.

Try checking "man mkbootdisk".

Of particular interest will be the "--size" argument.

-- 
Brian Ashe - CTO
Dee-Web Software Services, LLC.
http://www.dee-web.com/



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]