[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FC2 no grub.conf created

On May 20, 2004 at 12:53, B.J. McClure in a soothing rage wrote:

>Clean install of FC2 would not boot.  Grub supposedly installed to MBR
>of 40 gig IDE.  No other OS installed.  Boot attempts failed with the
>word "GRUB" displayed.  No command line.  Rescue disk could not locate
>grub.conf.  Tried writing to /boot, that didn't work either.  Did
>several fresh installs with identical results.

You know you only need one fresh install.

>Replaced 40 gig IDE with 20 gig IDE...same result.  Finally tried Custom
>> minimal install on 20 gig drive and it booted normally to CUI.  Then
>upgraded the install to "Workstation" default apps without rewriting the
>MBR.  Rebooted and it hung with grub> displayed.  Keyed in usual
>grub.conf lines, issued boot command and it did, GUI and all.
>Searched for grub.conf and there was none.  Created grub.conf in
>/boot/grub and all is well.

>Er, you got issues (-: Jokes aside, we need to know more
>about your hardware. Plus you need to boot with the
>rescue disk, chroot /mnt/sysimage, make sure a suitable
>/boot/grub/grub.conf exists and then
>grub-install --recheck /dev/hda .


Thanks for the input.  Your suggestion is essentially what I did.  It worked on the 20 gig drive but not the 40.  Finally burned the latest Bios revision and "Viola", everything played as advertised.

For anyone else on the list that might be interested the machine specs are as follows:

Mobo:        Asus A7V266-E  (onboard Promise Raid chip PDC20265R)
Bios:        Version 1006 w/n boot; Version 1011 works for me
Processor:   AMD 1.4 GHz Athlon
RAM:         512 Mb
IDE HDD:     WD400BB

For those that are smarter than I, the drive would boot when connected to the Promise IDE connector with the mobo jumper set for ATA100 instead of RAID.  However, the boot sequence failed because it could not sort out IRQ for hda.  Have not tried the Promise IDE since burning the new bios.  Very strange behavior...maybe the release notes for Bios Version might have a clue.  Hope this saves someone else some time.

Thanks again.

B.J. McClure

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]