Update broken, PCMCIA broken, up2date broken...

Chris Colohan colohan+ at cs.cmu.edu
Sat May 22 20:25:46 UTC 2004

I just installed FC2 yesterday, and had a number of issues with the 
install.  I was wondering how common these problems are (as were my 
friends at CMU, before attempting the upgrade themselves).

Background:  I am upgrading a laptop which was already running FC1.  The 
system was kept up to date with yum, and the only additional major 
change I made was to upgrade to KDE 3.2.2.  This laptop has run every 
version of RedHat since 7.1 without any problems.  I am doing the 
install from the ISO images stored on my hard disk, using the directions 
I have posted at:  http://www.colohan.com/docs/fedora_upgrade.html.  The 
laptop is a Dell Inpsiron 4000, 550MHz PII, 256MB RAM, plenty of free 
disk space, networked via a Lucent PCMCIA wireless card.

1.  Upgrading fails.  At first, I figured I would try to upgrade from 
FC1 to FC2.  The upgrade projected an install time of over 2 hours!  (By 
comparison, a fresh install took 25 minutes.)  After about an hour of 
crunching, the machine stopped doing anything while installing the 
umb-scheme RPM.  I let it hang for an hour, and killed the upgrade.  
(Given this vague description I decided not to file a bug report, since 
I am not sure how useful it is...)

I then decided to wipe my FC1 partition clean, and do a fresh install.  
It worked fine, until I rebooted....

2.  PCMCIA does not work.  This is a known bug, and has been known for 
quite some time!  
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=116205)  I am 
curious -- does this bug affect all PCMCIA systems, or just the one that 
I happen to have in my machine?  Needless to say, the system is pretty 
useless without PCMCIA, since this means I have no network connection...

3.  Libelf is installed incorrectly.  This is trivial to fix, and I 
filed a bug report:  
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123865  This also 
will probably not affect very many people...

4.  up2date doesn't work.  Frankly, I have never gotten up2date to work 
once, on any version of Redhat.  This version is prettier than most, 
until it hangs during package downloading.  I am not doing anything 
unusual -- just starting it up, and saying "yeah, upgrade everything 
that is out of date".  Most of my redhat running friends have never 
gotten it to work either.  Are we all on crack, or are we all missing 
something obvious?

Apart from these issues the upgrade went well -- it is nice to have KDE 
3.2.2 built in, and up2date has enough nice features that I really 
really wish it worked!  Thank you for your hard work...


Chris Colohan  Email: chris at colohan.ca       PGP: finger colohan at cs.cmu.edu
           Web:   www.colohan.com        Phone: (412)268-4751

More information about the fedora-list mailing list