[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Raw devices problem



Wolfgang wrote:

On Sat, 2004-05-22 at 08:22, Benjamin J. Weiss wrote:
On Thu, 20 May 2004, Wolfgang Gill wrote:

On Thu, 20 May 2004 00:56:48 +0000, Dan Haines wrote
Since posting this, I have found a command called: testlibraw

When I ran this, I get a response of:

couldn't get handle: No such device or address
This probably means that you don't have raw1394 support in the kernel or that you haven't loaded the raw1394 module.

I then searched the net looking for similar problems, and came across
this:

http://www.fedoraforum.org/forum/showthread/t-1700.html

I will give recompiling the kernel a go, and report back with my
findings.

Cheers,
Dan

On Thu, 20 May 2004 00:36:03 +0000
Dan Haines <dan haines metservice com> wrote:

Hi all.

Since upgrading to the 2.6 kernel, I am having the exact same problem
as this guy, word for word.  I have pasted the url, as there are
suggestions in the thread which have been tried by the user, and
myself, to no avail.  If anyone has any ideas, or information, please
post here!

http://www.webservertalk.com/message199531.html


Cheers,
Dan
<snip>

I had that problem too. (I have a digital camcorder that needs to use this
driver) The raw1394 module doen't install by default (for some reason). So I
simply added it to my /etc/rc.d/rc.local file by inserting a 'modprobe
raw1394'. Now when I reboot the system it loads automatically.

Well, I installed FC2, and when I try the modprobe it says that it can't find it. I tried "yum install raw1394" and *that* doesn't work either.

Wow, I'd hoped that FC2 would support my digital camcorder *better* than FC1. Instead, it doesn't support it at all.

Crap.

Any idea when the kernel will support firewire? I'm just *dreaming* of the day I can toss Win2K.

Ben

What about using the insmod raw1394, does that one work?? I don't run
the 2.6 kernel yet, so I don't know if that command works. I don't
intend to goto 2.6 until all the problems are resolved. (I would have
thought that this would all have been done with the 2.5 kernels)

Wolf
According to http://www.ic.unicamp.br/~oliva/snapshots/FC2-firewire/0README
which seems to reachable but not responsive at the moment:
"Fedora Core 2 ships with a kernel that's quite close to 2.6.6 and that, as such, has seriously broken Firewire modules, so they were disabled to avoid the problems described in section 0.1... ...The plan is to issue a kernel update for FC2 at some point, containing fixes for the problems described above."

So either try your chances adding firewire support as documented there or wait for the kernel update.

--
-----------------------------------------------------------
  "Spend less!  Do more!  Go Open Source..." -- Dirigo.net
  Chris Johnson, RHCE #807000448202021





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]