[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: So...um..has anyone gotten dual booting working with FC2?



On Sun, 23 May 2004 21:09:38 -0700
Sean Kennedy <skennedy tpno org> wrote:

> I've got two harddrives.  hda is my linux drive, hdb is my win2k drive.
> 
> The default grub config didn't boot my win2k partition, which isn't really a 
> shock as it never has.  But, neither did the grub config I had saved from my 
> fc1 install ( as follows )
> 
> root (hd1,0)
> map (hd0, (hd1)
> map (hd1), (hd0)
> chainloader +1
> 
> My ability with grub is limited enough that I don't really understand what is 
> happening in the above ( the maps are obvious, but why root() and 
> chainloader? ), so I have no clue on how to fix this.  I have read the info 
> pages on grub.conf, but from everythign I've read, this should work.
> 
> Has anybody gotten grub to work with a similar config?
> 
> Thanks

Hey Sean,

If  you can set LBA mode on your disk in the BIOS that should fix it.   Or 
boot into Fedora and run:

sfdisk -d | sfdisk -f -H255 -N1 /dev/hda

Where the number for the -N option should be the number for
your windows NTFS/FAT partition.

Check out these options too, second one shows how to use 
windows recovery console to fix windows:

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=115980

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=116653


Good Luck,
Sean





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]