[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

BIND issues with rndc



Hello all,

I recently upgraded my name server (running Red Hat) which upgraded
versions of BIND. The Red Hat has a GUI tool (redhat-config-named), which
I don't use; however it complicates things a bit as I now have to put my
definitions in a file called named.custom. The problem I'm having is when
I now start the service (or stop it) I get the following error:

service named restart
Stopping named: rndc: no key definition for name /etc/rndc.key
                                                           [FAILED]
Starting named:                                            [  OK  ]

I've read some on the rndc issue and I have read through the man pages but
so far I can't fix this problem. My named.conf (and named.custom) both
have the following:

include "/etc/named.custom"; (this is only in the named.conf)
include "/etc/rndc.key";

I already had an /etc/rndc.key file; however I wasn't sure if it was no
longer valid. I tried the following:

rndc-confgen -a

then tried to restart the daemon but without success

rndc-confgen

having no success with this either.

Can anyone point me in the right direction?

Thanks,

James




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]