FC2 doesn't see my sound card

Brian Kendig brian at enchanter.net
Mon May 24 20:49:07 UTC 2004

Fedora Core 2 doesn't see the sound card in my laptop.  When I run the 
"Soundcard Detection" program, all it does is give me a dialog saying 
"No soundcards were detected."

My laptop is a Dell Latitude D266XT, and the sound chip is a CS4237B on 
the ISA bus.  'lspci -v' shows nothing about it.  Under SuSE 9.0, I had 
gotten sound to work by putting this into /etc/modprobe.conf:

alias snd-card-0 snd-cs4236
alias sound-slot-0 snd-card-0
options snd-cs4236 port=0x530 irq=5 dma1=1 dma2=0 mpu_port=0x330 
mpu_irq=7 cport=0x210 fm_port=0x388 isapnp=0

So I tried putting that into /etc/modprobe.conf under FC2 (the file had 
no mention of any soundcard before I added this), and rebooting.  Now I 
get a speaker icon in the GNOME tray, and I can go into Volume Control 
to play with the volume sliders, but I don't get any sound, and the 
Soundcard Detection program still doesn't detect my soundcard.

How do I get audio to work under FC2 with my laptop?

More information about the fedora-list mailing list