[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

PCMCIA NIC eth0 could not be found



Hi,

I've got a problem which I hope is simple. I've still got a lot to learn w/Linux. I'm running FC2, but had the exact same problem with FC1.

I'm using a 3com pcmcia network card (3CCE589ET) on a Dell Latitude. No problems with the exact same setup on RH 9 or older. It always "just worked."

Now, however, eth0 is only detected and working on the first boot. Upon the second and all subsequent reboots, "ifconfig" gives the message "eth0 could not be found, delaying initialization." Same message in the boot process. Same message when I run system-config-network and click on "activate" the device.

There is a workaround, which is weird to me.
1. Go into system-config-network and remove the device AND the hardware. 2. Reboot
3. Go back to system-config-network and the hardware is already there. 4. "Add ethernet device" (3C589 series)
5. Everything is absolutely fine until the next reboot.
Note: this does not work if I try it without step 2. I tried replacing step 2 with "service-network-restart" and no luck.


Extra info, if it helps diagnose this:
I am using only one PCMCIA card (the only NIC). I did an HTTP install and had no problems during the install.
I don't fully understand "modprobe", but some lists recommended "modprobe 3c589_cs". This returned no errors.
modprobe.conf includes "alias eth0 3c589_cs"
Swapping with identical card does not help.


Please explain any solutions in detailed terms, as I am far from a Linux expert (obviously). Thanks very much in advance.

--
Mat





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]