[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: about WiFi cards





On Thu, 27 May 2004, Denny Figuerres wrote:



-----Original Message-----
From: fedora-list-bounces redhat com [mailto:fedora-list-
bounces redhat com] On Behalf Of Satish Balay
Sent: Thursday, May 27, 2004 10:48 AM
To: denny figuerres com; For users of Fedora Core releases
Subject: Re: about WiFi cards



On Thu, 27 May 2004, Denny Figuerres wrote:

Hi all, I have been a user of RedHat retail packages for a *LONG* time .
I
still have CD packages for 5.xx redhat.

In 8.xx I had no problem with a Microsoft mn-520 PCMCIA card, just had
to
edit a config file and it worked.

With Fedora Core 1 and 2 it's broke!

> Can anyone explain what has happened?

Same laptop, same card, the only difference is a newer version of Linux.


Do I have to go get the Linux-wlan-ng packages to deal with this?

Is there some deep reason that a working driver was broke?

Just trying to understand the problem before I start downloading stuff
and
spending time compiling and editing etc..

What driver was used with this card in RHL8? And what config files did you edit?

I'm guessing it was orinoco_cs and this driver is present in FC1 and
FC2. I have a Lucent Silver card - which works with this driver on
both FC1 & FC2.

Satish

Correct:  the Orinoco_cs driver works with 8 by adding a few lines to the
config file, the same change to the same file does not work with Fedora
Core.
I skipped RH9 so I don't know if it worked or was broke in 9.xx

If you do a search the changed are posted several places... let me see...
Here is one sample from a web page:
Just now I succeeded in using Microsoft's Wireless N/W hardware with RedHat
Linux 8. The hardware I used: 1. Microsoft Wireless Notebook Adapter MN-520
2. Microsoft Wireless Base Station MN-500
I added the following to /etc/pcmcia/config :

card "Microsoft Wireless Notebook Adapter MN-520 1.0.3"
version "Microsoft", "Wireless Notebook Adapter MN-520", "", "1.0.3"
bind "orinoco_cs"

I configured this device as eth1 and entered the following for Wireless
configuration: 1. Mode: Ad-Hoc 2. SSID Specified : my_wireless_network_name
Channel : 11 (I am using 11) Transmit : 11Mbps Key : my_encryption_key (for
128bit) This is working great for me.
This is very useful for anyone using dual boot (I am using XP and RHL 8). My
Windows XP uses the same hardware. Now RHL also uses the same hardware. If
you have any questions regarding my setup please feel free to contact me at

It works with 8, not with fedora, I have seen others say this when I was
searching the only answer I found was to use the linux-wlan-ng packages.

Can anyone shed some light on this??


When you say it doesn't work - does the driver load and not work? Perhaps you can try loading the driver manually - or make sure the string matches 'cardctl ident'.

I just noticed this. Someone has orinoco_cs working with this card on 2.6 kernel
http://forums.gentoo.org/viewtopic.php?t=115862&highlight=module+prism2cs

There is another alternative driver to prism2 - hostap. There are
prebuilt drivers for FC1/FC2 - which you might want to try.

http://bugzilla.fedora.us/show_bug.cgi?id=1019

Satish



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]