[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC2--can't get SMB share from nautilus



Yup. Got there after several missteps.

I had gotten close many times. First, I had started with "smb:///"
and gotten the computer's listed. I put smb:///SMITH/SMITH-D for
the name of the computer and share because "SMITH" is how the
computer is listed in the workgroup listing. Putting 2 slashes
in gets the same error.

The share when listed by Win98 until the listing is made all lower case.
(under Win4Lin) is "Smith/Smith-D".  Putting "smb://Smith/Smith-D"
fails as before. What worked finally is "smb://smith/smith-d"

OK, *nix is case sensitive but if nautilus wants to be fussy about
case sensitivity it probably shouldn't change the cases in the
process.

Anyway, thanks for your help. I think the mystery is solved
and is due to nautilus bugginess/quirkiness rather than a
misunderstanding about setting up samba.

Don
Gerald Thompson wrote:

Hi Don;

Ok I duplicated exactly what you went through.

First off the new nautilus interface for browsing folders by default is
dumb.  When you just double click on Computer or user's home on the
desktop you get that window with no menu bars that cannot be customized.

Here is what I finally found:
- right click on your Computer folder on desktop, choose Browse Folder.
- or click on Browse File system in the gnome menu
- you are going to have to click on Go at the top and go to Computer, if
you right clicked on Computer on your desktop you will already be there.
- you will now see a traditional nautilus window that you can actually
type your location into.
- double click on Network
- double click on your Windows Network
- double click on your work group
- you should now see the available computer shares
- if you double click on the computer you want you will get the error
that you mentioned in this e-mail.
- in location type smb://computer name/share folder name/
- you should get the password dialogue box now.  I got it.
- I think there is a bug in nautilus where you can only access a share
if you type in the full path of the share folder you need access to.

If I can figure out a way to get Nautilus to display the list of shares
under the computer name I will reply back.

What I did find out for you is that you have to go into browse mode in
order to access your share by typing it into the location bar.

So just right click on your desktop Computer icon, choose Browse Folder
and that will take you into browse mode.

Tyep in the direct path of your share folder

smb://computer name/share name/

you will get the password dialogue box.

Gerald Thompson










[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]