[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [OT] No swap device? was: how to restore LILO/partition table



On Sun, May 30, 2004 15:23:14 PM +0200, M. Fioretti
(mfioretti mclink it) wrote:

> On Sun, May 30, 2004 05:11:02 AM -0700, Mick Mearns (off_by_1 yahoo com) wrote:
> >  
> > 
> > Can you remove the hard drive and install from a desktop using an
> > adapter?
> > You should be able to clear the cmos somehow.
> > Do you have the utilty software that came with it?
> > 
> Still more details:
> 
> When it boots, it ends by saying
> 
>      Fatal error by reading from hard disk
>      Save To Disk feature is disabled
> 
> Marco.
> 

Partial success.

I have (writing it down also to not forget it...)

previously, during install I had:
       partitioned /dev/hdb1 as linux swap
       partitioned /dev/hdb2 as linux native, ext3

now I booted with tomsrtbt
(hard drive becomes hda, since cdrom is not in anymore, replaced by
floppy)

mounted /dev/hda2 to /mnt
chroot /mnt
edited /lilo.conf, changing all hda to hdb, hdb2 to hda2
run lilo

Now LILO *does* start and boot linux, but it stops like so:


Checking root filesystem
Possibly non-existent or swap device?
fsck.ext3: no such device or address while trung to open /dev/hdb2
			     [failed]


*** an error occurred during the file system check.
*** dropping to a shell. The system will reboot when you leave the
*** shell


Now, I guess I have to redo the substitution hdb -> hda somewhere
else, but where?

Ciao,
	Marco F.
-- 
Marco Fioretti                 mfioretti, at the server mclink.it
Red Hat for low memory         http://www.rule-project.org/en/

[Crash programs] fail because they are based on the theory that, with
nine women pregnant, you can get a baby a month.
						Wernher von Braun



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]