[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Prism2 Wireless on FC2? [SOLVED]



Cam wrote:

Dave

Does anyone know how I can get my wireless up and running?


You could try:

remove wireless card
use system-config-network to remove the configuration for the card
make sure there are no alias lines for your card in /etc/modprobe.conf
reboot with wireless card out to ensure it's modules are not loaded
insert wireless card
configure with system-config-network

Good luck,

-Cam


Great suggestion. This got me headed down the right path, but I needed to do a couple extra things to get up and running.

For any other folks in my situation (upgraded from FC1 to FC2, having used prism2 rpms from http://prism2.unixguru.raleigh.nc.us on FC1), here's what worked for me:
1. Boot my laptop with wireless card removed
2. Comment out "alias wlan0 prism2_cs" entries in /etc/modprobe.conf and /etc/modules.conf
3. Delete wireless card entries from system-config-network
4. Remove the prism2 rpms from my system
4a. rpm -qa | grep wlan
4b. rpm -e kernel-wlan-ng-0.2.1-pre14 kernel-wlan-ng-pcmcia kernel-wlan-ng-modules-fc1.1.2174-0.2.1-pre14 kernel-wlan-ng-modules-fc1.1.2188-0.2.1-pre14
5. Reboot
6. Once logged in, bring up a tail on /var/log/messages ("tail -f /var/log/messages")
7. Insert wireless card & verify the card is detected (should see a line show up in /var/log/messages like "May 30 13:20:18 hostname cardmgr[2584]: socket 0: Linksys WPC11 11Mbps 802.11b WLAN Card")
8. start system-config-network and create a new wireless device of type orinoco_cs. Configure the device as appropriate for your network.
9. Reboot
10. Enjoy your wireless


Hope this helps.
-dave






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]