[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FC2: firefox won't run after installing search and mouse plugins



Just put FC2 on a second machine at home.  It's great.
 Kudoes to the developers and testers.

For days, I've had firefox installed and running fine.
I had used apt and synaptic to get/install the
package.
Firefox was made the default gnome browser.  All good.
 Very good.

Today I decided to load some plugins.  I added about
eight search plugins and the mouse gestures plugin. 
All as a regular user (i.e. not root).  There was one
error message that popped to the screen during the
mouse gestures install which I think had to do with
not being able to write or create to a file.  I didn't
note the error, thinking the install would just be
aborted.  The next popup indicated the install had
completed successfully.  So, wondering if it had or
had not installed properly, I closed my firefox
program and tried to start it back up. 

But it won't start.  The symptom, when typing firefox
in a shell, is that after a few seconds, it ends. 
Nothing writen to stdout or stderr.  Nothing pops up. 
No new process created.  If I try to start it from the
gnome panel, a see a "Starting Web browser" window
being created, but after a few seconds it disappears.

I've uninstalled firefox, and reinstalled it, to no
avail.  I searched for a ~/.firefox directory.  One
didn't exist.  I've moved the ~/.mozilla directory out
of the way and the ~/.phoenix directory out of the
way, still no good.  I uninstalled firefox again, and
moved the /usr/lib/firefox directory out of the way. 
And reinstalled firefox.  Still no good.  I moved
/usr/lib/mozilla out of the way, and still firefox
just returns immediately.

I have not tried rebooting, but as this isn't Windows,
I wouldn't expect that to help.

What file/directory am I missing?  Or what package 
dependancy have I broken by uninstalling firefox and
reinstalling (all via synaptic)?  I may have made the
problem worse during this debugging because firefox
won't start under my root login any longer either. 
But admittedly I had installed the mouse gesture
plugin there too, but at least saw it work once as
root.  That install didn't cause a file/directory
failure message to be printed.  I did not install the
search plugins as root though.  Now after the
uninstall/reinstall.  Even root can't get firefox to
do anything.

-stuck


	
		
__________________________________
Do you Yahoo!?
Friends.  Fun.  Try the all-new Yahoo! Messenger.
http://messenger.yahoo.com/ 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]