[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: NFS mounting... bypass portmap



On Thu, 2004-09-30 at 19:26, Rick Stevens wrote:
> The option is "port=", not "mountport=".  The normal port to use is
> 2049.
> 

Tried that.  Its dying on trying to mount, not the nfsd port
specification.  If fact in using ethereal to sniff the handshake, it
appears that mount is using UDP for portmap to determine the nfsd port
to connect to.  But it uses TCP only for the mountd determination and
this is restricted in the router (TCP port 111 is blocked).  I've tried
"nfsvers=2" and "udp" with no luck.  It appears that mount tries to
access portmap and if it can't see it, assumes the server is dead...
even if mountport is specified.  

I'm beginning to think the only solution is to get the corporate
security group to open up port 111.

-- 
________________________________________________________
Daniel Vietor               Mail: devo ks unisys com
Unisys Corp                 Title: Engineer/Meteorologist
221 Gale Lane               Phone: 610-925-5206
Kennett Square PA 19348     Fax: 610-925-5215



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]