[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

login/kerberos strangeness



Well, maybe it is working the way it's supposed to but it appears strange to me.

Some time ago I found an old 486 machine lying around at work so I set it up to be an NTP server and a kerberos server. I added my login id, my desktop machine and a development machine as principles (if I remember the the terminology correctly) to the KDC and everything worked just fine.

Later I got a new desktop machine and I have installed FC2 on it. I did not install kerberos, although I see that the krb5-libs rpm is installed, and I did not add the new machine the the KDC. Recently I tried to log in to my new machine via gdm but I was unable to. I traced the problem to the fact that the NTP and KDC machine was turned off.

What I don't understand is why my machine was using the KDC to authenticate my login when I didn't tell it anything about the KDC. I do have the same login name on both my old and new desktop machines.

Can someone explain what is happening here? Does gdm use kerberos by default and somehow discovered that there was a KDC on the network?

Thanks,
Steve


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]