[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: GDM Crashes After Latest Xorg Updates for FC2



HD wrote:
Carlos Rodrigues wrote:

Hans Müller wrote:

Brian Hanks schrieb:

After applying the latest Xorg updates, I am now experiencing regular
GDM crashes while my system is idle.  There does seem to be much in the
logs other than the following:

gdm_slave_xioerror_handler: Fatal X error - Restarting :0

gdm_slave_exec_script: Failed starting: /etc/X11/gdm/Init/:0

gdm_slave_xioerror_handler: Fatal X error - Restarting :1



Any thoughts or suggestions would be greatly appreciated.




You are probably using the nvidia binary drivers right? If so, reinstall them and it will do it.

You can check this bug for more info: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=134289

Carlos Rodrigues

I have had a similar but more serious problem after installing the recent updated mentioned in the bug report. But I am not using nVidia drivers. I have a Radeon 7000 card and am using the default drivers that come with FC2.

My problem occured yesterday when I tried loging out of KDE. I recieved an error message saying the greeter had crached. After clicking OK on the error dialogue the greeter tried to restart but the error ocurred again. I had to leave for work at that time so I just shut off the computer. When I arrived home from work I could not get anything graphical to work. Not even the graphical boot would start. I them booted into windows and tryed to google for some information on the problem but didn't find anything useful at that time. So, I took drastic measures and completely reinstalled FC2. Though a bit of a pain for other reasons it did solve the problem and all things graphical are working again. I have since updated everything except xorg-x11 stuff and everything continues to work. Of course, I'm now scared to death to updated anything having to do with xorg-x11 :) I hope this information will help sort out the problem.

Also, I am still just in the learning stages of getting to know Linux and I realize there was probably a better way of getting FC2 to work again instead of reinstalling it. So, if anyone would like offer suggestions on how I could have handled this in a better way, please do :)

Thanks,
HD



This might be related to some changes introduced in this latest version of X. The problem with the radeon 7200 was experienced by myself and another user. The radeon 7200 is even worse than you describe the radeon 7000 problem. You get system lockups at boot.


One note: You should probebly file a bug in the xorg-x11 bugtracking system.

I filed the below bug for development. It might be helpful for them to know that the problem surfaces between version 6.7.0-5 and 6.7.0-9. This should narrow down the offending code, which breaks support for the radeon 7000 and 7200.

https://freedesktop.org/bugzilla/show_bug.cgi?id=1384

Also, version 6.7.0-5 is still available on the mirror. You might be able to upgrade to this and wait for the bug to be squashed which is in the -9 version.

Jim

--
"If I have trouble installing Linux, something is wrong. Very wrong."

- Linus Torvalds


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]