[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Probelm installing RPMs



Alexander Apprich wrote:

Tim,

Tim Bradshaw wrote:

I am running Fedora Core 2. Before now it has allowed installation via Install Packages without problem. Now I get an error message "Unable to read package. Be sure you have proper permissions to use this file." I checked the permissions and they are completely allowed, read-write-execute etc., and it shows my non-root user account as the owner. I tried to install via root login, but got the same error. Does anyone know what I'm doing wrong or have a suggestion as to what I shoudl try? Everything else on the system seems to work fine.


AFAIK a normal user can never install rpm's except they are relocatable,
or they are build using a non priviledged path.
Which files did you check? Did you change permissions for them before?
Try to rebuild you rpm database by executing (as root)

rpm --rebuilddb

Does this work without any errors? Have you tried different way to
install


Thanks



Alex

Haven't tried rpm --rebuildddb. Have been able to install rpms as non priviliged user by going in as root and giving access as memeber of rpm group in the past. But they won't install as root either. Will try the rebuilddb and let you know results.


Thanks


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]