[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Dumping to another servers tape drive

Bob Chiodini wrote:
On Tue, 2004-10-05 at 11:49, Douglas Phillipson wrote:

Wayne Leutwyler wrote:

On Oct 4, 2004, at 6:04 PM, Douglas Phillipson wrote:

I run:

/sbin/dump -0uf - /dev/sda9 | ssh rsldata 'dd of=/dev/nst0'

It seems to go to the tape fine. Then on rsldata I run:

/sbin/restore -if /dev/nst0

I get the error:

/sbin/restore: Tape block size (512) is not a multiple of dump block size (1024)

I've setup ssh so as to not require a password for sshing to rsldata.

I try to adjust block sizes in both "dd" and restore to no avail. Any idea what I'm doing wrong? This typically works fine on Unix (Solaris) but not Fedora.


Doug P

fedora-list mailing list
fedora-list redhat com
To unsubscribe: http://www.redhat.com/mailman/listinfo/fedora-list

Have you looked at Amanda? www.amanda.org

This might do what you are looking to do.

Thanks but I'm really just trying to get a dump of the machine prior to an upgrade. So I could still use some help with my question.


Doug P


Have you tried dd obs=1024 (or some multiple thereof).  Also, did you
rewind the tape before the restore (sorry :-)).


Thanks for the help Bob. I actually just found that if I do:

export RSH='ssh'
/sbin/dump  -b 2 -0uf rsldata:/dev/nst0 /dev/sda9

Then on rsldata do:

restore -if /dev/nst0

It seems to work properly. I would have thought that restore would have picked up the block size automatically, but apparently not if you don't specify a block size with dump.

Thanks to all that responded.


Doug P

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]