[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

USB key : /dev/sda1 not work; /dev/sda ok



Hi all,
Just try to mount USB key 256M on my FC2 box. I have kernel modules
like usb_storage, sg, vfat, sd_mod, scsi_mod.
When plug in I see:

scsi2 : SCSI emulation for USB Mass Storage devices
  Vendor: OTi       Model: Flash Disk        Rev: 2.00
  Type:   Direct-Access                      ANSI SCSI revision: 02
sda: Unit Not Ready, sense:
Current : sense = 70  6
ASC=28 ASCQ= 0
Raw sense data:0x70 0x00 0x06 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00
0x00 0x28 0x00 0x00 0x
00 0x00 0x00 
sda : READ CAPACITY failed.
sda : status=1, message=00, host=0, driver=08 
Current sd: sense = 70  6
ASC=28 ASCQ= 0
Raw sense data:0x70 0x00 0x06 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00
0x00 0x28 0x00 0x00 0x
00 0x00 0x00 
sda: Write Protect is off
sda: Mode Sense: 03 00 00 00
sda: assuming drive cache: write through
 sda: unknown partition table
Attached scsi removable disk sda at scsi3, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi3, channel 0, id 0, lun 0,  type 0
USB Mass Storage device found at 4
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
---------------------------------------------------------------------
So the command:

# mount -t vfat /dev/sda1 /mnt/usbkey

gives me the error:

mount: /dev/sda1 is not a valid block device

But when I try:

# mount -t vfat /dev/sda /mnt/usbkey   (yes, /dev/sda instead of /dev/sda1)

it works !
Any explanations ?

Thank you in advance

-- 
Quy NGUYEN DAI
http://vnoss.org/forum/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]