[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Netboot: kernel panic no init found



C. Linus Hicks wrote:

You stated earlier that the boot process dies with the "No init found"
message. Way before that, you should see something like this, except
your root will be different:

Kernel command line: ro root=/dev/hde7 rhgb console=tty0

I would make sure your command line doesn't have "quiet" on it, then you
will have to suspend output shortly after it starts booting. Use Ctrl-S
and Ctrl-Q to stop and start console output. Then you can use shift page
up and shift page down to scroll backwards and forwards.

None of the above key combinations do anything - the screen scrolls by and won't pause or scroll up. Looking for a line starting with "Kernel" as it scrolls past: couldn't see any.


I have managed to confirm that the command line specified is being read, because if I purposefully put bogus entries in the command line, the kernel stops booting with a corresponding error message.

What I still haven't figured out is why the kernel refuses to read it's init parameter from the initrd. The line "init=disklessrc" is included as a command line option, and the file "disklessrc" exists, yet the kernel still refuses point blank to acknowledge this.

Unfortunately the kernel doesn't tell you the name of the init file it is trying to bootstrap, so it remains a stab in the dark. I have tried swapping different kernels, I've tried using different client machines - no go no matter what I do.

Has anybody gotten diskless booting to work ever? If so, was there something special you needed to do to make it work?

Regards,
Graham
--

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]