[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

module vermagic problem



I needed to build some kernel modules for lirc but to make this i needed
to generate version.h. I copied
/usr/src/linux/configs/kernel-2.6.8-i686.config to /usr/src/linux/.config.
I ran make menuconfig and launch make for few seconds. All was fine except
that the version for the module was '2.6.8-1.521custom 686 REGPARM
4KSTACKS gcc-3.3 and should be 2.6.8-1.521 686 REGPARM 4KSTACKS gcc-3.3. I
don't know how to solve this. When i run modprobe lirc-atiusb i obtained :
Error inserting lirc_atiusb
(/lib/modules/2.6.8-1.521/misc/lirc_atiusb.ko): Invalid module format
I hope this error is caused by the version mismatch ?
Thanks
Eric




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]