[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yum update for FC2



Dave Close wrote:

<cut>
....Unable to satisfy dependencies
Package subversion needs libswigpy.so, this is not available.
Package subversion-perl needs libswigpl.so, this is not available.

# rpm -q -f /usr/lib/libswigpy.so
swig-1.3.21-2
# rpm -q -f /usr/lib/libswigpl.so
swig-1.3.21-2
# rpm -qa | grep subversion
subversion-devel-1.0.3-1
subversion-perl-1.0.3-1
subversion-1.0.3-1


There are only two reasons:
1. If a package must be removed for incompatibilities, yum does not mark the dependencies of that packages as "to be removed", so the first check fails. This means that for some incopatibilities swig and subversion must be removed, but subversion needs this two packages.


2. Any of the update needs a new version of swig and subversion: it does not found them, so it give the files as missed.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]