[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

hard disk crash

Hi everybody.

I am running FC1 and one of my hdd crashed: i can't even mount it.

It is a reiser partition on a 70Gb SCSI disk. I tried with reiserfsck
--rebuild-tree -S /dev/sdc1 - after waiting for a long time, looked like
it had fixed something. However, i still can't mount the partition.
Mount reports some errors (sorry, can't be more specific right now, but
it is the usual error - unable to mount, bad superblock or too many
mounted file system...).

So i tried with reiserfsck --rebuild-sb /dev/sdc1, that didn't work.

So i tried with the scsi adapter utility and verified media. Looks like
some sectors are indeed damaged, and the verify utility claimed it was
able to flag them as corrupted and make the disk usable again.

It didn't work either.

Now, i'd like to save all that i can from that disk, and then i'd try to
format and see if i can recover it. However, i can't even mount it so i
really don't know what to do. I read somewhere that i could try to 'dd
if=/dev/sdc1 of=/dev/newparition', and also that it is supposed to work
even with unmounted partition. Anybody tried this out? ANy hints? I
wonder why i am not able to mount the partition if reiserfsck
--rebuild-sb says that the superblock is good.

Thanks a lot.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]