[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Permissions for mounted NTFS drive



On Wed, 2004-10-27 at 16:56, Mark Knights wrote:
> Hi all,
> 
> I have mounted my two XP NTFS drives successfully however am having
> troubles with accessing them.  I can get temporary access by going in as
> root and setting permissions to all users for modify and read access but
> that dies after about an hour or so.  
> 
> My etc fstab lines look like....
> 
> /dev/hda1 	/mnt/win1 		ntfs 	nosuid,rw	0 0 
> /dev/hdb1 	/mnt/win2 		ntfs 	nosuid,rw	0 0
> 
> and that mounts them fine at boot.  
> 
> I found this thread at Fedora Forums
> http://www.fedoraforum.org/forum/showthread.php?t=22035
> which suggests I use;
> 
> /dev/hda1 /mnt/win1 -t ntfs -r -o umask=0222

I don't hakve any problem with this command, but you want want to look
at linux-ntfs.sourceforge.net and they docs they provide.  
> 
> in fstab so I tried it out.  It worked like a charm and gave me full
> access to the drives.  But, when I reboot it does not remount the drives
> and when I go to mount or unmount other things it tells me that the
> lines that contain that code contain errors?
> 
> Can anyone give me a foolproof way for these drives to be mounted on
> startup and allow full access to all users?

Personally, I would recommend NOT having write access to an NTFS
partition from linux.  It's just not safe.  Make the partition ro and
copy all the data to an NFS partition or something.  I've never had
anything but bad luck with trying to write NTFS from linux.  Hell, I'm
lucky if I can get Windows to write to NTFS!


> 
> Cheers
> 
> Mark

--------------------------------------
Mark Haney
Network Administrator
InterAct Public Safety Systems
mhaney interactsys com
Fedora Core release 2 (Tettnang) Kernel: 2.6.8-1.521 GNU/Linux 
17:01:26 up 9:22, 1 user, load average: 3.89, 3.04, 2.47 

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]