[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Sendmail configuration



I have a small problem with my sendmail config. I am sure I have missed
something, but I just can't see what.

I currently have a solaris system running sendmail, and that works fine.
I copied the configs from that system and started up sendmail. The new
FC2 system happily sends mail to our mail hubs, but when it receives a
message it just sends it back to the mail hub.

I've done a few tests and found that it will accept and deliver mail to
a local user and a local mailing list, however if I send a mail to
any_mail_address adastral ucl ac uk it just sends it to the mail hub
(which sends it back and we get in an eternal loop).

I have set all my locahost host names in local-host-names.
I have put adastral.ucl.ac.uk in relay-domains
My aliases file is straight from the Sun box so it works ok.

I have set :

MASQUERADE_DOMAIN(adastral.ucl.ac.uk)dnl
MASQUERADE_AS(`adastral.ucl.ac.uk')dnl

In the sendmail.cf.

The last thing in my config which is a little strange is the MX records
for my domain point to the mail hub and not to my server, this is to
allow all mail from external addresses to pass through a central mail
hub before being delivered to local mail servers. This does however work
fine with the Solaris system.  

Can anyone help?

Mny thanks,

Neil.

-- 
Neil Marjoram.
Systems Manager
University College London
Adastral Park Campus
Martlesham Heath
Ipswich
Suffolk
IP5 3RL

01473 663711


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]