[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: dependency problem with latest updates nvidia-related



Clint Harshaw wrote:
Need some help diagnosing a problem when I ran up2date to get the latest updates. What should I do to resolve this?

Thanks,
Clint

Name                                    Version        Rel
----------------------------------------------------------
[...]
kdegraphics                             3.2.2          1.1  i386
kdegraphics-devel                       3.2.2          1.1  i386


Testing package set / solving RPM inter-dependencies...
warning: package nvidia-glx = 0:1.0.6106-0.lvn.4.2 was already added, replacing with nvidia-glx <= 0:1.0.6111-0.lvn.2.2
There was a package dependency problem. The message was:


Unresolvable chain of dependencies:
nvidia-glx-1.0.6111-0.lvn.2.2 requires kernel-module-nvidia = 0:1.0.6111



Additional information that may be helpful:
I just installed this nvidia video card. I tried the following command after the installation but it failed for reasons I don't recall now:


# yum install nvidia-glx kernel-module-nvidia-`(uname -r)`

After that failed, I dl'd the driver from nvidia's site and followed the alternate instructions found at this url:

http://www.fedorafaq.org/custom_nvidia.html

That went fine (with the exception of the rivafb error that others had, and I ignored the error).

So I suspect this dependency issue is related to my failed attempt at installing the nvidia driver with yum. When I try to find nvidia-glx I get this output:

# locate nvidia-glx
/var/cache/yum/livna-stable/headers/nvidia-glx-0-1.0.6106-0.lvn.4.2.i386.hdr
/var/cache/yum/livna-stable/headers/nvidia-glx-devel-0-1.0.6111-0.lvn.2.2.i686.hdr
/var/cache/yum/livna-stable/headers/nvidia-glx-0-1.0.6111-0.lvn.2.2.i686.hdr
/var/cache/yum/livna-stable/headers/nvidia-glx-devel-0-1.0.6106-0.lvn.4.2.i386.hdr

and when I try to find kernel-module-nvidia I get no output, indicating it's just not there.

Anything else I could run or report to help troubleshoot?

Clint


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]