[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: please assist: yum strangeness, can't update anymore




On Fri, 29 Oct 2004, Angelo Machils wrote:

> Hello there.
> 
> I'm using the yum.conf from http://www.fedorafaq.org/#yumconf and now I get
> this message when I try to do an update:
> inding updated packages
> Downloading needed headers
> Resolving dependencies
> .Package vlc needs libdvdnav.so.0, this is not available.
> Vlc is the latest version (0.7.2) and libdvdnav.so.0 is available in the
> /usr/lib directory. The version of  libdvdnav is
> libdvdnav-0.1.9-3.1.fc2.fr.....

This is a repository problem with 'vlc' (whichever repo it came from)

There is a new version of libdvdnav - but 'vlc' which is currently
installed (from the same repository?) depends on the old libdvdnav
currently installed. (so the new libdvdnav package breaks this
dependency)

The solution is to have an updated vnc build with the updated libdvdnav

If you don't care for the new libdvdnav - just do:

yum --exclude=libdvdnav update

Satish


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]