[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: audacity segfaults on FC2



On Sat, 30 Oct 2004 13:01:19 +0200, Hannes Mayer wrote:

> Thanks for the hint! Didn't look at fedora.us.
> But this binary also segfaults...
> 
> audacity depends on wxWidgets, so I did a search for it:

Where do you see such a dependency?

> # rpm -qa | grep wx
> wxGTK-devel-2.4.2-1
> wxGTK-common-2.4.2-0.fdr.2.2
> wxBase-2.4.2-1
> wxGTK-2.4.2-1
> wxGTK2-2.4.2-0.fdr.2.2

The wxGTK, wxBase and wxGTK-devel versions are not from fedora.us.
Not that this would be the problem, but mixing repositories causes
a multitude of run-time problems.

$ rpm -qa 'wxGTK*'
wxGTK-common-2.4.2-0.fdr.2.2
wxGTK-2.4.2-0.fdr.2.2

> No wxWidgets. Maybe that is the problem ?
>
> On the other hand why did the rpm install, when wxWidgets is not present ?

Because the package depends on wxGTK, which is the project/package
name for the GTK/GTK+ port of the wxWidgets library. It's also known
as wxWidgets/GTK (and its old name wxWindows/GTK).

-- 
Fedora Core release 2 (Tettnang) - Linux 2.6.8-1.521
loadavg: 0.05 0.30 0.18


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]