[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum errors



On Mar 31, 2005 11:19 PM, Paul Howarth <paul city-fan org> wrote:
> On Fri, 2005-04-01 at 10:38 +0530, gaurav wrote:
> > hi list,
> > I am facing getting lot errors while using yum (lots of HTTP Error 400)
> > and in end I get IndexError: list index out of range
> >
> > why its happening ....
> >
> > xorg-x11-libs-6.8.2-1.FC3 100% |=========================| 277 kB    00:25
> > ---> Package xorg-x11-libs.i386 0:6.8.2-1.FC3.13 set to be updated
> > ---> Downloading header for gamin to pack into transaction set.
> > http://www.las.ic.unicamp.br/pub/fedora/linux/core/updates/3/i386/gamin-0.0.25-1.FC3.i386.rpm:
> > [Errno 4] IOError: HTTP Error 400: Bad Request ( The data is invalid.  )
> >
> > http://www.las.ic.unicamp.br/pub/fedora/linux/core/updates/3/i386/gamin-0.0.25-1.FC3.i386.rpm:
> > [Errno 4] IOError: HTTP Error 400: Bad Request ( The data is invalid.  )
> > Trying other mirror.
> > Traceback (most recent call last):
> >   File "/usr/bin/yum", line 8, in ?
> >     yummain.main(sys.argv[1:])
> >   File "/usr/share/yum-cli/yummain.py", line 104, in main
> >     (result, resultmsgs) = base.buildTransaction()
> >   File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 174, in
> > buildTransaction
> >     (rescode, restring) = self.resolveDeps()
> >   File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 148, in
> > resolveDeps
> >     self.populateTs(test=1)
> >   File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 106, in
> > populateTs
> >     self.downloadHeader(po)
> >   File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 454, in
> > downloadHeader
> >     end=end, checkfunc=checkfunc, copy_local=1)
> >   File "/usr/lib/python2.3/site-packages/yum/repos.py", line 443, in get
> >     checkfunc=checkfunc)
> >   File "/usr/lib/python2.3/site-packages/urlgrabber/mirror.py", line
> > 414, in urlgrab
> >     return self._mirror_try(func, url, kw)
> >   File "/usr/lib/python2.3/site-packages/urlgrabber/mirror.py", line
> > 392, in _mirror_try
> >     mirrorchoice = self._get_mirror(gr)
> >   File "/usr/lib/python2.3/site-packages/urlgrabber/mirror.py", line
> > 290, in _get_mirror
> >     return gr.mirrors[gr._next]
> > IndexError: list index out of range
> 
> Can you post your /etc/yum.conf and /etc/yum.repos.d/fedora-
> updates.repo ?
> 
> Can you also confirm that you're running yum 2.2?
> $ rpm -q yum
> 
> Paul.
> --
> Paul Howarth <paul city-fan org>
> 

Paul, the OP found the earlier posting of [ Yum 2.2 w/ HTTP proxy
fails w/ error "Cannot find a valid baseurl for repo:" ].  There is no
need to continue this thread since it just wastes bandwidth.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]