[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: screen flashing to black every several seconds



Jim Cornette wrote:

Claude Jones wrote:

Jim Cornette wrote:
 >

Download all the xorg related rpms into a local directory and then run the command below from within this directory where you placed the rpms.

rpm -Uvh *.rpm --oldpackage

while you are root and preferably you are out of X and in a terminal. This should replace the new packages with the older versions. If you find that there are additional programs/libraries that also need to be rolled back, place these rpms within this directory and repeat the command above again.

I would *not* advice rpm -e or yum erase for going back in X versioning.


I have spent the better part of this day trying to understand how to do this without damaging my system. I learned much, but I was still far from feeling confident about trying something. Thank you for these instructions...



One added note regarding this procedure. It might be wise to do an
rpm -qa |grep xorg
To see which rpms that are currently installed on the system. The reason is that the U means that any package installed or not will be upgraded/installed. The F (freshen) option did not seem to work for me when trying to downgrade with --oldpackage option to rpm.


The procedure worked for several that tried this to downgrade xorg-x11 packages when a major failure hit us on testing FC3 to be.

It is safer than removing x packages via rpm -e and does not remove your desktop managers like yum erase xorg-x11 would do.

Jim

Jim: Just to let you know that this worked perfectly! It would seem that there is a concatenated series of actions that led to this mess. The first was the installation of the Radeon driver from ATI. This was followed by the application of xorg-x11-6.8.2. I've now rolled back the process by first removing the Radeon/ATI driver, and then by rolling back xorg. During the removal of the ATI driver, I got a message about a conflict between that driver and something on my system which I unfortunately didn't write down. So, my question is, do you think I should try reinstalling the xorg update now that the system is working again?

--
Claude Jones
Bluemont, VA, USA


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]