[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: APT needed file missing from Download Library



On Apr 1, 2005 7:21 PM, Lloyd Hayes <lloyd545220-trucker yahoo com> wrote:
> >
> >
> >>
> >
> >>It appears that the newest version of APT, "apt-0.5.15cnc7-1.i386.rpm"
> >> needs "libapt-pkg-libc6.3-6.so.2" which is not in the "Extras" download
> >> library for FC3.
> >
> >
> >It is:
> ># rpm -q --whatprovides libapt-pkg-libc6.3-6.so.2
> >apt-0.5.15cnc7-1
> >
> >So, ... what's your problem?
> 
> -----------------
> 
> ------------------------------------------------------------------------
> 
> The problem is that "apt-0.5.15cnc7-1.rpm" will not install without "libapt-pkg-libc6.3-6.so.2" present. It's not in the download library.
> 
> I get the same error when I run any of the following:
> 
>     rpm -Uvh apt-0.5.15cnc7-1.i386.rpm
>     rpm -Uvh apt-devel-0.5.15cnc7-1.i386.rpm
>     rpm -Uvh apt-groupinstall-0.5.15cnc7-1.i386.rpm
>     rpm -Uvh apt-python-0.5.15cnc7-1.i386.rpm
> 
> These RPMs need this library before they can be upgraded.

where is the output of above commands?

libapt-pkg-libc6.3-6.so.2 is not a package, but a library, and it is
included in the main apt package.

just don't install a newer ``apt'' package from somewhere else which
doesn't contain this library.

-- 
Bernd ``learn to trim your mails!'' R.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]