[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Up2date on FC3 64bit



Doug Coats wrote:
> I just purchased a new computer with the AMD 64bit processor.  I installed
> FC3 on it yesterday using the 64bit version.  When I went to use up2date I
> noticed both 32bit and 64bit files for upgrades.  Many of the 64bit files
> would not install, complaining about conflicts with the 32bit versions that
> were already installed.  The 32bit versions would not install either.

I explained that 64 bit systems need 32 bit libraries if they are to run
certain programs, like OpenOffice.

Manny wrote:

> I've been experiencing the same problem as well. I've tried several
> things and nothing has worked. I've even gone to the update site and
> tried doing it from there but I get the same errors, which is
> "conflict with xxxx file"

We need to know the "xxxx".

Are you using yum or up2date? Can you give us the precise error message:
we need to know which file is conflicting with which package.

It would also be helpful if you did a 
rpm -q --queryformat '%{NAME}-%{VERSION}-%{RELEASE} %{ARCH}\n' $PACKAGE
where $PACKAGE is the package you're having trouble with.

For example,
[james kendrick ~]$ rpm -q --queryformat '%{NAME}-%{VERSION}-%{RELEASE} %{ARCH}\n' glibc
glibc-2.3.4-2.fc3 x86_64
glibc-2.3.4-2.fc3 i686

And can you do a
rpm -qf --queryformat '%{NAME}-%{VERSION}-%{RELEASE} %{ARCH}\n' $FILE
on the file $FILE.

Thanks,

James.

-- 
E-mail address: james | Hooray. "I'm Sorry I Haven't A Clue" is back on,
@westexe.demon.co.uk  | complete with strip poker. Yes, this is on the radio.
                      | ("Erm..  five queens", "Barry, you're playing with
                      | postage stamps", "Oh.") -- Telsa Gwynne


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]