[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: missing dependency php



On Sun, 2005-04-03 at 22:16 -0700, Kam Leo wrote:
> On Apr 3, 2005 10:05 PM, Michael A. Peters <mpeters mac com> wrote:
> > 
> > On 04/03/2005 09:36:30 PM, Jeff Vian wrote:
> > 
> > >
> > > Do you have any repos except fedora base and fedora updates enabled?
> > >
> > > If you do it may be trying to install a version of php-ldap and
> > > php-pear
> > > that is not compatible with the version of php installed.
> > >
> > > Check that and disable all that are not the fedora repos first.
> > 
> > I bet that's the case.
> > repositories are designed to solve what is known as "dependency hell" -
> > but when repositories exist that break the core repository, it just
> > reverts to the same dependency hell problem.
> > 
> > I really wish more of the repositories out there would seriously commit
> > to not breaking core/extras.
> > 
> > --
> > Michael A. Peters
> > http://mpeters.us/
> > 
> 
> Per her response to Craig she's got fedora-devel.repo,
> fedora-updates.repo, and fedora-updates-testing.r epo (sic). She does
> not have a fedora base.
> 
And fedora-updates-testing and and fedora-devel can cause this kind of
breakage since they are unstable...... Hence the names. 

Having a package installed from the devel tree can break an update from
the update tree.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]