[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fedora-list Digest, Vol 14, Issue 47 Subject: grub-install seems to be wiping my partitions



I installed Windows xp on my first partition, and then installed FC3 on
my second partition. Instead of making the second partition logical, I
made it bootable (forced primary) and chose it to be ext3. All other
partitions, you can make it either logical or primary, it wouldn't
matter. On the grub loading section, you will add it to your second
primary, which is ext3, the FC3 installation partition. Once you've
done that, you should have no problem booting up your windows 2000 (or
windows xp in my case) and FC3.

Shen-En Chen (from Waco, TX)
dreamcarrior yahoo com


--- fedora-list-request redhat com wrote:

> Send fedora-list mailing list submissions to
> 	fedora-list redhat com
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	http://www.redhat.com/mailman/listinfo/fedora-list
> or, via email, send a message with subject or body 'help' to
> 	fedora-list-request redhat com
> 
> You can reach the person managing the list at
> 	fedora-list-owner redhat com
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of fedora-list digest..."
> 
> 
> Today's Topics:
> 
> 
> Message: 5
> Date: Mon, 4 Apr 2005 17:13:50 -0400
> From: Duncan Lithgow <dlithgow gmail com>
> Subject: grub-install seems to be wiping my partitions
> To: fedora-list redhat com
> Message-ID: <b4422cb050404141333b61aba mail gmail com>
> Content-Type: text/plain; charset=ISO-8859-1
> 
> Sounds strange to you too? It does to me, here\s what\s happening...
> 
> I recently installed win2000 at the front of my drive, knowing it
> would mess my boot loader (grub) but expecting I could fix it, I have
> before.
> 
> So I threw in FC3 disk one, got to the command line chrooted to
> /mnt/sysimage and ran grub/install hd0. Maybe that wasn\t a good idea
> after all...
> 
> On rebooting it seemed to work when I booted into windows so I
> thought
> I\d try fc3 and rebooted. Grub Error 22, something about can\t find
> stage1-5. So, I put FC3 Disk1 in again and ran that - this time it
> refuses to mount the old system saying "no linux partitions found" -
> my blood pressure rises...
> 
> I thought "that can\t be and threw in PartitionMagic - "partition
> Table error", So I tried Knoppix, it found two drives, one the
> win2000
> partition and the other and unmountable, unrecognised section. It
> should have found about 7.
> 
> So, I guessed that I\d somehow lost my partitions and went looking
> for
> a solution. Found TestDisk, got win2000 installed again - that being
> the only partition I could risk playing with. Ran TestDisk, great wee
> program, worked fine, found the 'deleted' partitions and restored
> them
> - windows could see the big fat32 partition with all my non-system
> files and things looked good. But then as I went through the process
> of getting grub working, same as above - it did the same thing again.
> 
> So now I\m using gmails web interface and Knoppix and hoping someonw
> knows what's going on - I'm going to bed.
> 
> Duncan
> 



		
__________________________________ 
Yahoo! Messenger 
Show us what our next emoticon should look like. Join the fun. 
http://www.advision.webevents.yahoo.com/emoticontest


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]