[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

losing interfaces and setting up route tables



Hello people,
I have been having fun setting up a USB adsl modem. I have the eciadsl driver synching to the usb port but I can't seem to get the route table to set up to use the interface properly.
This driver uses the tap0 interface and sometimes this seems to disappear. When I issue ifconfig -a it is sometimes there, somtimes not. However even when it is there I can't get
# route add default dev tap0 (or ppp0)
to add a gateway. The script connecting me presumably has the same difficulty. The message is
SSIOCTL:no such device. (sorry not the exact words, I am tired and not doing everything well).
Other messages I can remember say things such as ...
No I'll come back later with the exact messages.
My eth0 was hogging the gateway before but I still get the same problem when unplugged the lan cable.
However has this problem arisen before? I am using FC1 with 2.4.26.11 on an old Compaq Pentium 3. And am using rp-pppoe. I have configured it to run on tap0.


Is setting up an ethernet modem very much easier? I'm worried that even if I spent the money for one that I'd still have problems. Especially if it's not the USB part but the networking set up for the internet.

I used to have a dial up connection that worked with no problems.

Shelagh


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]