[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum update problem



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Julien Le Houérou wrote:
| Hi, as I run 'yum update' everything runs, is downloads the packages to
| update,
| and after running transaction check it tells "package <---> needs <--->
| free space on filesystem /".
|
| I got large free space even after downloading the packages....
|
| So i cd to the dl directory and run "rpm -Uvh <package>, and it updates".
|
| When I run "rpm -Uvh *" it comes back telling me it needs free space".
|
| Anyone knows about that?

I have only ever seen this when I truly did need more space on my
filesystem.  What does df -h have to say?

Don't forget that downloading all those RPMs will have eaten a bunch of
space (in /var/cache/yum ... maybe time for a clearout of any ancient,
already installed RPMs in there...)

If you find a bunch of ancient packages mixed in with ones you just
downloaded, running this from the directory in question will just nuke
ones older than 5 days (change to suit taste).

rm -f `find . -name "*.rpm" -type f -mtime +5`

Otherwise yum clean will zap all these package caches for you
automatically to recover space.

- -Andy


-----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.1 (GNU/Linux) Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iD8DBQFCU+BnjKeDCxMJCTIRAu4NAJ9ZyIuBxXQgMVwEZkS6IgCsWInK1QCfUtJF
mKFTaeiDpemCOSZ+v1Tz55k=
=OezC
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]