[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Trying to compile NetworkManager



Timothy Murphy wrote:
I'm running Fedora-3 with KDE.
I've been trying to get a recent version of NM working on my laptop.
(I was told this might help get NM running with my Orinoco Gold PCMCIA card.)

I first tried to install NetworkManager-0.4-6.cvs20050404.i386.rpm
but this came up with a huge list of required packages
which are not available in Fedora Core updates.
I don't want to install a large number of rawhide packages,
as the last time I did this it caused confusion (mainly due to the new python)
which took a long time to correct.

So then I downloaded the CVS files following the instructions at
<http://people.redhat.com/dcbw/NetworkManager/downloadcontribute.html>,
and ran "./autogen.sh --prefix=/usr --sysconfdir=/etc" as advised.
This failed at the "configure" stage, but created a configure file.
On running configure I get the error below,
saying that I require hal >= 0.2.91 ,
although I appear to have hal-0.4.7.
Apparently configure is lookint for the file hal.pc
which does not appear to be part of my system.

================================================
[tim martha NetworkManager]$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
...
checking for hal >= 0.2.91... Package hal was not found in the pkg-config search path.
Perhaps you should add the directory containing `hal.pc'
to the PKG_CONFIG_PATH environment variable
No package 'hal' found


configure: error: Library requirements (hal >= 0.2.91) not met; consider adjusting the PKG_CONFIG_PATH environment variable
if your libraries are in a nonstandard prefix so pkg-config can find them.
[tim martha NetworkManager]$ grep hal /var/log/rpmpkgs
hal-0.4.7-1.FC3.i386.rpm
hal-cups-utils-0.5.2-8.i386.rpm
[tim martha NetworkManager]$ locate hal.pc
[tim martha NetworkManager]$
================================================


Any suggestions or advice gratefully received.

When you are building software, you need the -devel packages for the libraries you are using (in this case you need hal-devel) in addition to the regular "runtime" libraries.


# yum install hal-devel

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]