[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Loading bttv module at boot?



As promised, here are the relevant lines from my
modprobe.conf to get the bttv loaded at boot:

# ATI Wonder bt878 frame grabber with Philips MI1236
NTSC tuner, found by system
alias char-major-81 bttv
# finds wrong tuner, so state explicitly; options are
pll=0,28,35
options bttv card=63 tuner=2 pll=28 

That's all I have. I don't know what your second line
char-major-81-0 does? Is it required? Can you explain?

Mine, however, does the job of loading the card at
boot to /dev/video0 and the card is fully functional
in every way I can determine so far.

There is one minor oddity. Perhaps someone could
explain. As you can see, I have stated the tuner
explicitly. If I remove the options tuner=2 line, the
system thinks I have the wrong tuner. Yet, if I state
it explicitly, as I have, everything works 100%:

kernel: Linux video capture interface: v1.00
kernel: bttv: driver version 0.9.15 loaded
kernel: bttv: using 8 buffers with 2080k (520 pages)
each for capture
kernel: bttv: Bt8xx card found (0).
kernel: bttv0: Bt878 (rev 2) at 0000:02:0d.0, irq: 9,
latency: 32, mmio: 0xef000000
kernel: bttv0: detected: ATI TV Wonder [card=63], PCI
subsystem ID is 1002:0001
kernel: bttv0: using: ATI TV-Wonder [card=63,insmod
option]
kernel: bttv0: using tuner=2
kernel: bttv0: i2c: checking for MSP34xx @ 0x80...
found
kernel: msp34xx: init: chip=MSP3445G-B8 +nicam +simple
+simpler +radio mode=simple
kernel: msp3410: daemon started
kernel: bttv0: i2c: checking for TDA9875 @ 0xb0... not
found
kernel: bttv0: i2c: checking for TDA7432 @ 0x8a... not
found
kernel: bttv0: i2c: checking for TDA9887 @ 0x86... not
found
kernel: tuner: chip found at addr 0xc0 i2c-bus bt878
#0 [sw]
kernel: tuner: type set to 2 (Philips NTSC
(FI1236,FM1236 and compatibles)) by bt878 #0 [sw]
kernel: bttv0: registered device video0
kernel: bttv0: registered device vbi0
kernel: bttv0: PLL: 28636363 => 35468950 .. ok
kernel: bt878: AUDIO driver version 0.0.0 loaded
kernel: bt878: Bt878 AUDIO function found (0).
kernel: bt878(0): Bt878 (rev 2) at 02:0d.1, irq: 9,
latency: 32, memory: 0xee800000

As you can see from the log, up at the top, the kernel
says bttv, using tuner=2, and then down lower, it says
tuner, type set to 2. This is somewhat odd, as it
suggests to me that the kernel correctly identified my
tuner, meaning that I would not need to explicitly
state that I have tuner=2, yet when I remove tuner=2,
then the tuner gets set incorrectly. Very strange, but
I have tried every possible permutation and this
redundancy seems to be necessary.

Also, I am not 100% certain about which is the correct
pll setting. My card works so well that I haven't
tried any other settings. Yet, looking at the log
fragment I have just inserted above, I see that pll 28
=> 32. Does that mean the system has overridden my
setting and found a better one? 

I hope this helps, and if someone can help me
understand some of the questions I have posed above,
please do. It is appreciated.

Thanks,Pete

______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]