[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Loading bttv module at boot?



John,

I don't quite understand 100%. The bootup output says the card is
automatically detected and loaded to dev/video0 at boot. Yet, you say
that when you have to reboot, you have to manually modprobe it? You
mean to say that when you cold boot the pc, it loads, but when you do
a reboot, it doesn't?

{Thanks for the tip about dev/audio. Does dev/audio work with alsa, or
only the old, uh, what are they called, oss drivers? I could never
figure out why I was only getting video, but no sound. LOL}

Well, until it all gets solved, why don't you just put the modprobe
bttv into the rc.local for a while and perhaps we'll think of
something in the days to come? Maybe someone else has some knowhow.
Unfortunately, it seems that not so many people are into these tv
cards. They're big in Europe, but this side of the Großer Teich, most
just want their humungous television sets. Me, I like to see tv in a
little window on my monitor and would like to use my hard drive as a
video machine.

So, how is MythTV? I have perused the setup instructions some, but
thought I'd let it mature a bit before I give it a try. I think it was
up to 0.15 when I last looked. I would be fascinated to get it going,
but dread the thought of yet another reason to sit at this screen for
a whole week until 5 am. I keep saying that, but in the 20+ years of
hobbying around with these machines, I have learned that even the
dumbest little problem costs a gruelling, mind-wracking and sleepless
week. Always! I just can't seem to get around it. But then it's 100%
solved.

I don't think it could be Conexant. What is significant, I think, is
that it is the bt878 chip. But I can't be positive, of course.

I had a difficulty when I first got my card going. I also have a
webcam and the webcam would get discovered and loaded before the frame
grabber. I had to manually remove the webcam modules to free video0,
then load the ati frame grabber and let it become video0 and then
reload the webcam to make it video1 (yes, I put this into rc.local for
a while). It was a pain, but when we transitioned from the old
modules.conf to modprobe.conf, it just resolved itself. Now, the bttv
frame grabber is automatically video0 without me intervening. Do you
have a webcam or some similar device that might be messing things up?
Have you studied the boot output line by line to see if there are any
errors somewhere or the system making guesses because of an ambiguity
or misconfiguration somewhere? I don't think there was much in your
modprobe.conf, just a sound card and the bttv, I think. Do you have
any other devices that should be there that you're getting loaded just
by luck? There must be a glitch somewhere. The bttv is suposed to be
the best supported tv capture card for Linux.

Sorry I couldn't be of any further help, but keep posting your
thoughts, suspicions, and results and maybe the background radiation
of our thoughts will turn up something while we're not thinking.

Pete, er, uh... kwhiskers ;-)

On Apr 11, 2005 12:10 AM, Rahul Sundaram <sundaram redhat com> wrote:
> John L. Pierce wrote:
> 
> >kwhiskers, the card has worked flawlessly for about 1 month now, tvtime,
> >zapping, xawtv, and even recording live tv with mythtv.
> >
> >All of this since day I installed the card.
> >
> >I have no complaints with its operation, the problem has always been the
> >loading of the bttv module at boot time.  If for any reason I have to
> >reboot the system I must manually modprobe bttv to load it.
> >
> 
> The goal is of course to get it to work without manually fiddling with
> anything. Do file a bug report in bugzilla.redhat.com
> 
> regards
> Rahul
> 
> --
> fedora-list mailing list
> fedora-list redhat com
> To unsubscribe: http://www.redhat.com/mailman/listinfo/fedora-list
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]