[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Force Webalizer Install



On Mon, 2005-04-11 at 17:20 -0700, Rudi Starcevic wrote:
> Hello,
> 
> I'm trying to install Webalizer.
> 
> As I'm using my own compiled Apache I cannot use Yum as it wants 
> dependencies.

The cleanest fix for this is to build your own Apache RPM (tweak the
official one with your changes) so that the dependencies will be
satisfied.

> So while trying to install the rpm is get this error:
> 
> [root cogent6 src]# rpm -Uvh --force webalizer-2.01_10-15.ent.i386.rpm
> warning: webalizer-2.01_10-15.ent.i386.rpm: V3 DSA signature: NOKEY, key 
> ID 0c98ff9d
> error: Failed dependencies:
> webserver is needed by webalizer-2.01_10-15.ent
> Suggested resolutions:
> httpd-2.0.46-44.ent.centos.2.i386.rpm

This appears to be a Centos system, not a Fedora system.

> Hmm .. not sure why, this worked fine on my other Fedora Boxes.
> 
> Can you tell me why I can't force install ?

--force is not a way of avoiding dependencies.

> Or how I can make it ignore dependencies?

Use --nodeps instead of --force. But building your own apache RPM would
be *much* better, and you'll still be able to understand rpm's output in
the future, which won't be the case if you screw up your system by
installing with --force or --nodeps.

Paul.
-- 
Paul Howarth <paul city-fan org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]