[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Configuration problem with bind gives DNS delays



Hi !

I have a problem with delays in DNS lookup.

I have a closed network with a windows2003 nameserver (xxx.yy.16.12) and
have tried to setup a slaveserver (xxx.yy.16.15) on my FC3 server.

If a have my slaveserver in /etc/resolv.conf i get problems with delays.

If I do "ftp machine" i get a ~10 seconds delay before getting prompt
from the ftp-server.
If I do "ftp machine.mydomain.se" i get prompt instantly. Same for ssh/telnet/rsh.

I can see in the logs and in the dns-files that machine exists.

My /etc/nsswitch.conf:
..
hosts:	files dns
..

My /etc/resolv.conf:
search mydomain.se
nameserver xxx.yy.16.12
nameserver xxx.yy.16.15

My /etc/named.conf (slightly edited to protect the innocent:
// Default named.conf generated by install of bind-9.2.4-2
options {
        directory "/var/named";
        statistics-file "/var/named/data/named_stats.txt";
        dump-file "/var/named/data/cache_dump.db";
};
zone "mydomain.se" {
        type slave;
        file "slaves/mydomain.se.zone";
        masters {
                xxx.yy.16.12 ;
        };
};
zone "yy.xxx.in-addr.arpa" {
        type slave;
        file "slaves/mydomain.se.rev.zone";
        masters {
                xxx.yy.16.12 ;
        };
};
include  "/etc/rndc.key";

Any suggestions ?

Regards
-- 
Karl-Olov Serrander kase cntw com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]